Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Changes between Version 53 and Version 54 of 2.0/changelog


Ignore:
Timestamp:
02/11/09 14:11:55 (10 years ago)
Author:
Gustavo
Comment:

added 2.0b6

Legend:

Unmodified
Added
Removed
Modified
  • 2.0/changelog

    v53 v54  
    11= Change Log = 
     2 
     3== 2.0b6: (**unreleased**) == 
     4 
     5=== Features === 
     6 
     7 * The repoze.what integration is now provided by the new [http://code.gustavonarea.net/repoze.what-pylons/ repoze.what-pylons] package. 
     8 * For Python 2.6 users, introduced the class decorator @allow_only to set controller-wide authorization. It's an alternative to ''Controller.allow_only''. 
     9 
     10=== Fixes === 
     11 
     12 * ''@tg.require'' set the status code to 401 when authorization was denied, regardless of whether the user was anonymous or not. From now on, a 403 status is used when the user was authenticated. 
     13 
     14=== Backwards Incompatible Changes === 
     15 
     16 * If you relied on the ''Controller._check_security()'' method, then you have to call it from ''Controller.!__before!__()'' because it's not called anymore by TG. 
     17 
     18=== Known Issues === 
     19  
     20* None 
    221 
    322== 2.0b5: (**Febuary 4, 2009**) ==