Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Changes between Version 9 and Version 10 of DebianInstall


Ignore:
Timestamp:
07/18/06 08:01:28 (13 years ago)
Author:
mgeisler
Comment:

Add proper links to the bug numbers

Legend:

Unmodified
Added
Removed
Modified
  • DebianInstall

    v9 v10  
    11== Debian Packaging == 
    22 
    3 Unlike other Linux distributions, Debian systems use a strict package management system. This system "owns" certain directories. If a user installs files into the directories, he is likely to corrupt the system. Unfortunately, the current TurboGears install instructions for *nix systems will override filesystem permissions, deposit files ino those directories, and corrupt your Debian system (possibly quite badly!). This is listed as bug 273. 
     3Unlike other Linux distributions, Debian systems use a strict package management system. This system "owns" certain directories. If a user installs files into the directories, he is likely to corrupt the system. Unfortunately, the current TurboGears install instructions for *nix systems will override filesystem permissions, deposit files ino those directories, and corrupt your Debian system (possibly quite badly!). This is listed as bug #273. 
    44 
    55Instead of those directions, there are two solutions for installing TurboGears. You can do it through the Debian package system, by trying to create a Debian package representing the python module (method 1). Or you can set up configurations so that the python packaging system will respect the boundaries required by Debian packaging system (method 2). 
     
    105105}}} 
    106106 
    107 A known-good variant of these instructions is also available at bug ticket 273. 
     107A known-good variant of these instructions is also available at bug ticket #273.