Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Changes between Version 1 and Version 2 of ExtendingQuickstart


Ignore:
Timestamp:
10/27/05 12:20:17 (9 years ago)
Author:
ianb@…
Comment:

Added a little Why section

Legend:

Unmodified
Added
Removed
Modified
  • ExtendingQuickstart

    v1 v2  
    11With TurboGears 0.9 (or svn rev 106) quickstart now uses PasteScript and therefor supports user templates. 
    2 So lets go ahead and create one of those! 
     2 
     3== Why? == 
     4 
     5Why would you want to do this?  Well, if you have your own conventions for applications, this is a way to add those to new TurboGears projects -- documentation templates, testing frameworks, whatever.   
     6 
     7Also, if you already have a project started, you can apply run quickstart on it again (perhaps with your new template!) and see how the current project differs, and maybe apply some of the changes. 
     8 
     9== How? == 
     10 
     11So lets go ahead and create our own template! 
    312 
    413lets say that you have a default.css file that you always include in your webapp.