wiki:FreeBSDInstall
Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Version 1 (modified by SuperJared <jared.kuolt@…>, 9 years ago) (diff)

--

Installing TurboGears on FreeBSD

This document currently applies to FreeBSD 6.0-RELEASE, though will most likely work with older versions (5.x likely, 4.x less likely).

Prerequisites

The standard  TurboGears *nix install works so we'll just work with the prerequisites. First, you must have Python installed. Thankfully, FreeBSD 6 ships with Python 2.4.

Install from ports:

$ su
password:
$ cd /usr/ports/lang/python
$ make install clean

Or the package install (easier, less time consuming).

$ su
password:
$ pkg_add -r python

Database Connectivity

SQLite

From ports:

$ su
password:
$ cd /usr/ports/databases/py-PySQLite2/
$ make install clean

Package install:

pkg_add -r py24-pysqlite2

MySQL

From ports:

$ su
password:
$ cd /usr/ports/databases/py-MySQLdb/
$ make install clean

Package install:

pkg_add -r py24-MySQLdb