wiki:InstallBehindProxy
Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Version 1 (modified by jorge.vargas, 13 years ago) (diff)

I have seen this in the list more then ones

If your here probably you have run into the same problems. You can't run easy_install and get something like this

TODO reproduce error messsage

Therefore here is the tip, there is an  environment variable:

easy_install -f http://www.turbogears.org/preview/download/index.html TurboGears

Linux

export http_proxy="http://your.proxy.com:yourPort"

Windows

tested on XP

set HTTP_PROXY=http://your.proxy.com:yourPort

you can also use the "" in windows

Mac

TODO

after that go back to your easy_install command

Work Around

if by some change you can't set the proxy or want to do an offline install download all the eggs and run easy_install with local packages.